Announcing the new Datavyu v1.3.6 with enhanced features and transcription support!

Hi all, after I launch Datavyu I click on "Add Data" then find my video, but I keep getting the same error message:

"Could not open data source: Non-Java exception raised, not handled! (Original problem: * -(__NSArrayM objectAtIndex:): index 1 beyond bounds for empty array)"

It's weird because an hour ago it worked fine. I tried restarting the computer which didn't help. I checked my version of Quicktime and its 10.4. Im working with Datavyu v1.3.4 on a Mac.

A colleague has been experiencing the same problem recently but it comes and goes- some days it works, some days it doesn't.

Any help would be greatly appreciated!

asked 17 Nov '16, 07:57

cwright's gravatar image

cwright
26113
accept rate: 0%

Does this happen with a particular video or are all videos failing to open in Datavyu? My guess would be the video plugin is having difficulty opening specific video files.

(17 Nov '16, 17:41) Shohan Hasan ♦♦ Shohan%20Hasan's gravatar image

Hi Shohan, I tried several different videos and it happens with all of them..different video file types (.mpg, .mp4, etc), and different locations (server and desktop).

(21 Nov '16, 06:12) cwright cwright's gravatar image

I will follow up with you via e-mail so we can discuss this in more detail. I will post the final resolution here as an answer for other users afterwards.

(21 Nov '16, 16:34) Shohan Hasan ♦♦ Shohan%20Hasan's gravatar image

Hi Shohan, thanks for your email and help. I realised I never responded to you- sorry about that. We figured out the problem that day, heres what happened- Some of the videos we use were exported from Project Pro in MPEG2 format. If you tried to load one of these videos it caused Datavyu to "break" and after that Datavyu would then not be able to load any other videos until restarting the program. Each time I restarted the program I tried with that same video, thus effectively breaking it all over again. Now we're reexporting them in H.264 format if need be- then they work just fine.

(28 Nov '16, 03:51) cwright cwright's gravatar image

I'm glad to hear that you guys found a way to fix the issue. Thank you for sharing the resolution with us and other Datavyu users. We will try to figure out why working files break after failing to open specific video formats.

(02 Dec '16, 18:10) Shohan Hasan ♦♦ Shohan%20Hasan's gravatar image

Hi Shohan,

same thing happening here! Had some troubles yesterday, i.e. could not open any .mp4 files - but .mov worked fine. Today cannot open these same .mov files either.

Also tried various video locations (server/desktop) and various file types (.avi/.mov/.mp4). Nothing worked. Always receiving same error message (as above cited): "Could not open data source: Non-Java exception raised, not handled! (Original problem***- [__NSArrayM objectAtIndex:]: index 4 beyond bounds [0.. 3])"

Using Datavyu 1.3.4 on a Mac, under OS X El Capitan (10.11.6) - tried both, VLC and QT plugins, no success.

Really appreciate your help here - many thanks in advance!

permanent link

answered 23 Nov '16, 15:47

nrichter's gravatar image

nrichter
112
accept rate: 0%

Hi, I haven't found a resolution to this issue to post on the forum yet so I will contact you via e-mail to investigate in more detail.

(28 Nov '16, 17:40) Shohan Hasan ♦♦ Shohan%20Hasan's gravatar image
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×31
×12
×10

question asked: 17 Nov '16, 07:57

question was seen: 1,510 times

last updated: 02 Dec '16, 18:15

powered by OSQA